UpPreviousNext

Integrating Builder Xcessory with Your Environment

Builder Xcessory is one of many tools that can be used in the design and implementation of an application. Rather than attempting to provide the entire environment for application development, Builder Xcessory integrates with the tools in your own environment.

Sun, SGI, and DEC

If you use SunSoft Workshop, Silicon Graphics Developer Magic or DEC FUSE you can install Builder Xcessory into your environment. You can then access the tools in your environment from within Builder Xcessory. Integrating with these tools greatly expands the capabilities and usefulness of Builder Xcessory when used throughout a project cycle.

Environment services

The following table provides an overview of the environment services available from Builder Xcessory and the conditions under which they are available:

Environment

Services

BX Command
Line Flag

SunSoft Workshop 2.0 Tools

MakeTool, Debugger, test tools, error checking tools, Source Code Control, Code Center/Object Center

-workshop

DEC FUSE 2.0 (or later) Tools

Builder, Code Manager, test tools, error checking tools, Source Code Control

(none)

SGI Developer Magic 2.4 (or later)

Build Analyzer, Debugger, test tools, error checking tools, Source Code Control

-devmagic

custom environment

Test tools, error checking tools, Source Code Control, Code Center/Object Center

N/A

Once installed in your development environment, you can start Builder Xcessory, use Builder Xcessory to work on user interface design, and access other development tools in your environment directly from Builder Xcessory. For example, you might start up Builder Xcessory from your environment and design a small portion of a user interface, test it in Play Mode, use your environment's debugger to debug it, and then return to Builder Xcessory to continue working on your user interface design.

Using Builder Xcessory with Your Tools

Before you can use Builder Xcessory with the tools in your development environment, you must first install Builder Xcessory into your environment. Refer to the Builder Xcessory Installation Notes for a detailed description of the installation process.

Using Builder Xcessory with DEC FUSE Tools

The DEC FUSE tools are launched from a small control panel. The tools use DEC MCMS (MultiCasting Message Service) as the underlying message layer.

To use Builder Xcessory with DEC FUSE tools, select Builder Xcessory from the control panel Tools menu.


Note: If you wish to use Builder Xcessory with DEC FUSE tools, you must start Builder Xcessory from the DEC FUSE control panel. There is no command-line switch to allow Builder Xcessory to initialize DEC FUSE communication.

Using Builder Xcessory with SunSoft Workshop Tools

The SunSoft Workshop tools can be used separately or from a small tool control panel. The tools use ToolTalk as a system for passing messages.

To start Builder Xcessory with SunSoft Workshop tools, use one of the following methods:

· Double-click on the Builder Xcessory icon in the Workshop Manager.

· Start Builder Xcessory from the command line with the -workshop flag. This flag tells Builder Xcessory to initialize ToolTalk messaging with the Workshop messages.


Note: When working with Workshop, you need to launch Builder Xcessory from Workshop in order to control the Builder Xcessory windows from the Workshop Manager.

Using Builder Xcessory with Developer Magic

The SGI Developer Magic tools can be invoked separately or from a small tool control panel. The tools use ToolTalk as a system for passing messages. For example, the debugger can tell the editor to load a file.

To start Builder Xcessory with Developer Magic, use one of the following methods:

· Select Builder Xcessory from the Launch menu of any of the Developer Magic tools.

· Start Builder Xcessory from the command line with the -devmagic flag. This flag tells Builder Xcessory to initialize ToolTalk messaging with the Developer Magic messages.

From your environment manager, you can stop, iconify, and deiconify Builder Xcessory. You can also raise Builder Xcessory windows.


Note: Unless otherwise noted, all customization options are saved between invocations of Builder Xcessory.

Designing Your Application in an Integrated Environment

The steps for building an application are basically the same, regardless of whether you use Builder Xcessory from a development environment or whether you use Builder Xcessory independently:

· When using Builder Xcessory with a development environment, you can use that environment's build or make tool.

· When using Builder Xcessory independently, you can use Code/ObjectCenter on Sun platforms to manage the make. Otherwise, you must manually run the make command at a UNIX prompt.

Selecting a build or make tool

When developing an application in Builder Xcessory, you can use your environment's build or make tool at any time. You must tell Builder Xcessory which tool you want to use, verify that your makefile parameters are correct, and then execute a build of your application.

To use your environment's build or make tool, follow these steps:

1. Select Tools Preferences from the Browser Options menu to display the Tools Customization dialog.

2. If you use your environment's build or make tool, skip to step 4.

3. If you want to use CodeCenter or ObjectCenter to manage the build instead of the environment-provided tool, select Use CenterLine Tools from the Debugger and Build Manager tab (see Debugger & Build Manager with Centerline Defaults ).

 

Debugger & Build Manager with Centerline Defaults


Note: If you are using a CenterLine tool to manage the build, the language you chose specifies the command line used to start the tool. (Generating C or UIL/C uses the C command. Generating C++ or ViewKit uses the C++ command.)

4. Verify the make parameters by selecting Code Generation Preferences from the Browser Options menu to display the Code Generation Preferences dialog, and then clicking the Makefile tab ( Makefile Tab on the Language Settings Dialog ).

 

Makefile Tab on the Language Settings Dialog

5. Change any incorrect parameters.

6. To execute a build of your application, select Make Application from the Browser Project menu.


Note: If you are using Builder Xcessory outside of a development environment and Code/ObjectCenter is not available on your platform, Make Application is not available. Instead, you must run the make command manually.

Builder Xcessory actions

When you perform the preceding steps, Builder Xcessory:

· Generates all source code and files in the language you specified.

· Tells your environment to begin a build through that environment's build manager or make tool.

· Reports the status of the build in the Browser message window.

Example

This example assumes you are using Builder Xcessory with DEC FUSE, Developer Magic, or Workshop, and you are ready to execute a build of your application in C. (The procedure is similar in other languages.)

To execute the build, follow these steps:

1. Select Code Generation Preferences from the Browser Options menu to display the Code Generation Preferences dialog.

2. Click on the Makefile tab.

3. Verify the parameters on the Makefile Customization dialog.

4. Select Make Application from the Browser Project menu.


Note: If the DEC FUSE Builder is not already running, it starts automatically. The first time it runs, you must enter the Makefile name in the configuration dialog. In any subsequent session it is not necessary to enter the Makefile name.

While your application is building, any related messages are displayed in the message area of the DEC FUSE Builder, Developer Magic Build View, or Workshop MakeTool.

Example

This example assumes you are using Builder Xcessory without a development environment, and you are ready to execute a build of your application in C++. (The procedure is similar in other languages.)

To execute the build, follow these steps:

1. Select Tools Preferences from the Browser Options menu to display the Tools Customization dialog.

2. Click on the Debugger & Manager tab ( Debugger & Build Manager Tab on the Tools Customization Dialog ):

 

Debugger & Build Manager Tab on the Tools Customization Dialog

3. Select Use CenterLine Tools from the Debugger & Build Manager tab.

4. Select Code Generation Preferences from the Browser Options menu to display the Code Generation Preferences dialog.

5. Click on the Makefile tab ( Makefile Tab on the Language Settings Dialog ):

 

Makefile Tab on the Language Settings Dialog

6. Verify the C++ parameters on the Makefile tab.

7. Select Make Application from the Browser Project menu.

8. Use Code/ObjectCenter to manage the make.


Note: On platforms that support Code/ObjectCenter, you can use Code/ObjectCenter instead of the environment's make manager.

While your application is building, messages are displayed in the Browser message area.

UpPreviousNext