UpPreviousNext

Using a Debugger

While you are developing your application, you can debug it at any time without leaving Builder Xcessory.

If you are using Builder Xcessory with SunSoft Workshop or Silicon Graphics Developer Magic, you can access that environment's debugging tool or a CenterLine debugger.

If you are using Builder Xcessory on HP-UX platforms, CenterLine is the only debugger available.

Using your environment's debugger

To start your environment's debugger from Builder Xcessory, follow these steps:

1. Select Tools Preferences from the Browser Options menu to display the Tools Customization dialog.

2. Click on the Debugger & Build Manager tab.

3. On the Debugger & Build Manager tab, choose Use Environment Tools from the option menu.


Note: Select Use CenterLine Tools if you prefer to use CodeCenter or ObjectCenter rather than your environment's debugger.

4. To start your debugger, select Debug Mode from the Browser Project menu.

When you perform this procedure, Builder Xcessory:

· Generates all source code and files in the language you specified.

· Builds the code.

When the build is complete, Builder Xcessory loads the executable file into your environment's debugger, which is displayed on your screen.

Example

This example assumes you are using Builder Xcessory with SunSoft Workshop, and you are ready to execute a build of your application in C++.

To execute the build, follow these steps:

1. Select Tools Preferences from the Browser Options menu to display the Tools Customization dialog:

 

Tools Customization Dialog

2. Select Use Environment Tools from the Debugger option menu.

3. Select Debug Mode from the Browser Project menu.

Builder Xcessory generates the code and files in C++, and causes the code to be built. The executable file is then loaded into Workshop' Debugger and displayed on your screen.

Using the CenterLine debugger

To start either of the CenterLine debuggers from Builder Xcessory, follow these steps:

1. Select Tools Preferences from the Browser Options menu to display the Tools Customization dialog.

2. Click on the Debugger and Build Manager tab.

3. In the Debugger & Build Manager section of the Tools Customization dialog, set the Execute CenterLine Command toggle to the desired value.

Setting the toggle causes Builder Xcessory to try to start a CenterLine tool if Builder Xcessory cannot communicate with a currently running process.
Unsetting the toggle causes Builder Xcessory to cease attempting to communicate with a currently running process.

4. Check the message and command input fields and make any changes.

5. To start either of the CenterLine debuggers, select Debug Mode from the Browser Project menu.

When you perform this procedure, Builder Xcessory:

· Generates all necessary source code and files in the language specified.

· Sends the C or C++ Message to Code/ObjectCenter, which by default causes Code/ObjectCenter to load and run the application.

UpPreviousNext