UpPreviousNext

Accessing Source Code Control Systems

While using Builder Xcessory, you can check out and check in files from a source code control system without exiting Builder Xcessory. If you are using Builder Xcessory from a development environment, you can access that environment's source code control system. If using Builder Xcessory as a stand-alone program, you can use RCS, CMS, SCCS, ClearCase, or a system you specify. If properly configured, Builder Xcessory can automatically check out UIL files under Source Control.

Regardless of whether you are using Builder Xcessory with a development environment or not, the steps you take to select and use a source code control system are the same.

Selecting a Source Code Control System

To select a source code control system from Builder Xcessory, follow these steps:

1. Select Tools Preferences from the Browser Options menu to display the Tools Customization dialog ( Tools Customization Dialog ).

2. On the Source Code Control tab of the Tools Customization dialog, choose the name of the system you want to use from the option menu. The default option is Unset .

If you are using Builder Xcessory with FUSE, select Use Environment Manager from the option menu.

3. If you want Builder Xcessory to automatically ask you whether or not to try to check out read-only UIL files when they are read in, set the Check Out Read- Only Files toggle. Otherwise, Builder Xcessory will read the file but not overwrite it.

4. Check that the commands displayed on this dialog are correct. If you want to make any changes, enter them directly in each input field.


Note: The commands text fields are only sensitive if the Source Code Control option is set to a source control system . For more information, see Editing the Commands for Source Code Control .

5. Dismiss the Tools Customization dialog.

Editing the Commands for Source Code Control

If you have chosen a Source Code Control option, the text fields for the source code control commands will be sensitive. This section describes the edits you may want to make to those commands.

Any commands you enter in the command text fields should be suitable for passing to sh -c . The commands should also require no user intervention.

Builder Xcessory processes the command before executing it, in order to substitute any options you set on the Check In and Check Out dialogs (Browser:Project). (These dialogs are discussed in detail in Using a Source Code Control System .)

Entering a new source control command

Use the following notation to enter a new source code control command:

%file[option_specification %s]
%overwrite[option_specification]
%version[option_specification %s]
%keep[option_specification]
%comments[option_specification %s]

Builder Xcessory will copy option_specification and add the text in %s when one of the above options is indicated from the Check In or Check Out dialogs.

Example

For example, you can specify a version string for a file in both the Check In or Check Out dialogs. How this string is passed to the source code control commands varies from system to system. Suppose the check out command for the source code control system you are using is check_out , and in order to specify a version to check out you would enter:

check_out -v "version_string"

In Builder Xcessory you would enter:

check_out %version[-v "%s"]

When Builder Xcessory attempts to check out a file, it looks for %version in the command string. If you have specified a version string in the dialog, Builder Xcessory will add the option you specified within the square brackets and replace the %s with the string entered in the Check Out dialog.

Using a Source Code Control System

This section describes first how to check a file out of source code control, then how to check it back in.

Checking a
file out

To check a file out of source code control, follow these steps:

1. Select Check Out Source from the Browser Project menu to display the Check Out dialog:

 

Check Out Dialog

2. Set or remove any check out options you want.

You can choose one of the following options:
· Lock a file when you check it out
· Check out a read-only version
· Remove a lock that you have set
In addition, you can specify a version string number, or overwrite a read-write version of a file that is currently checked out.

3. Navigate through your directory structure in the Directories window of the dialog, if the directory you want is not already displayed.

4. Select the file you want to check out from the Files window in the dialog. The full pathname of the file you selected is now displayed in the Selection input field.

5. To check out the file, click on Apply .

Checking a
file in

Once you have finished modifying a file, you will need to check the updated version back into your source code control system. To do so, follow these steps:

1. Select Check In Source from the Browser Project menu. This displays the Check In dialog, as shown in Check In Dialog .

 

Check In Dialog

2. Select the file name you want to check in from the list of files displayed.

3. Specify comments for your modifications in the comments field.

4. If you want to keep a read-only copy of the file, set the Keep File Copy toggle.

5. To check the file back in, click on Apply .

Example

This example assumes you are using Builder Xcessory without an external development environment, and you are ready to check a file out of SCCS, modify the file, and check it back into SCCS.

Selecting SCCS as the source code control system

To select SCCS as your source code control system, use the following steps:

1. Select Tools Preferences from the Browser Options menu.

2. In the Source Code Control option menu, choose Use SCCS .

3. Check that the commands displayed on this dialog are correct.

4. Dismiss the Tools Customization dialog.

Checking a file out of SCCS

To check a file out of SCCS, use the following steps:

1. Select Check Out Source from the Browser Project menu.

2. Set the Check Out Locked toggle on the Check Out dialog.

3. Set the Overwrite Existing File toggle on the Check Out dialog.

4. Navigate through your directory structure in the Directories window of the dialog, if the directory you want is not already displayed.

5. Select the file you want to check out from the Files window in the dialog.

6. To check the file out, click on Apply .

Checking a file in to SCCS

After modifying the file, use the following steps to check in back into SCCS:

1. Select Check In Source from the Browser Project menu.

2. Select the file name you want to check in from the list of files displayed.

3. Document the changes you have made to the file in the comments field.

4. To check the file back in, click on Apply .

UpPreviousNext