UpPreviousNext

Using a Memory-Access Error-Checking Tool

You can also specify a memory error-checking tool to use with your code.


Note: The only error-checking tools currently available for Builder Xcessory are Purify and MemAdvisor.

Selecting an error-checking tool

To specify an error-checking tool, follow these steps:

1. Select Tools Preferences from the Browser Options menu to display the Tools Customization dialog.

2. Click on the Test Tools tab ( Test Tools Panel on the Tools Customization Dialog ):

 

Test Tools Panel on the Tools Customization Dialog

3. On the Test Tools tab of the Tools Customization dialog, select Purify Command, MemAdvisor Command, or Other Command.

4. Set the toggle to select that tool.

Connecting
to an error-
checking tool

When you select a test tool, Builder Xcessory adds targets for that tool to the makefile. When you build your code, you can use the pure target to build an instrumented version of your application. When you run your application, the error-checking tool provides information about memory usage and errors in the object code. The executable provides information about memory leaks and accesses.

UpPreviousNext