UpPreviousNext

Palette

Palette object icons

The Palette displays labeled, iconic representations of the UI objects with which you build your interface. Depending upon the currently selected language and the platform on which you are running Builder Xcessory, the Palette icons correspond to the following objects:

· Motif Xm widgets

· ViewKit ObjectPak Vk objects

· EnhancementPak Xi widgets

· Java AWT objects

· DEC Dxm widgets (available only on DEC UNIX platforms)

· SGI Sgm widgets (available only on SGI platforms)

· Common Desktop Environment (CDE) Dt widgets (available only on platforms with CDE and BX CDE support)

The Palette also includes collections of objects and classes that you build, as well as any third-party or platform-specific widgets or classes you add to Builder Xcessory.

For more information about the Palette, refer to Palette . For more detailed information about the Palette objects, refer to Palette Objects .

EPak widgets

To include EnhancementPak widgets on the Palette, use the Start with EPak Widgets toggle button on the User Preferences dialog of the Browser Options menu. For more detailed information, see Behavior toggle options .


Note: To compile an interface that uses EPak widgets, you must have the EnhancementPak library installed on your system. The EnhancementPak library is included with BX PRO.

ViewKit objects

The ViewKit ObjectPak objects are automatically included on the Palette when you select ViewKit as your default language. For more detailed information, see Choose A Language .


Note: TTo compile an interface that uses ViewKit objects, you must have ViewKit installed on your system. ViewKit is included with BX PRO.

Palette views

The Palette can be viewed in outline or tabbed form (Figures Builder Xcessory Palette (Outline View) and Builder Xcessory Palette (Tabbed View) ):

 

Builder Xcessory Palette (Outline View)

 

Builder Xcessory Palette (Tabbed View)

Palette Groups

On the Palette, UI objects are divided into groups. The groups and their contents vary depending upon the selected language. For a description of the standard Palette groups, see Palette Groups . For more detailed descriptions of each object on the Palette, refer to Palette Objects

Nesting groups

You can nest groups by creating a new group as part of another group. For example, create a "ViewKit' group and move all ViewKit-related groups into the "ViewKit" group. You can then hide all the ViewKit items by closing just the single group.

Hiding/
displaying groups

To hide a group, click on the folder icon to the left of the group name. Click again on the icon to restore the view of the group.

Creating a top-level group

To create a new top-level group, select New Group from the Palette Edit menu.

Creating subordinate groups

To create a new group subordinate to an existing group, select New Group from the Palette MB3 Quick Access menu.

Groups common to all Palettes

In addition to the platform- and language-dependent groups, the Palette displays the following groups:

· Project Classes

High-level UI objects you create or for a project when you open a project save file.

· Private Classes

High-level UI objects that are stored in the following directory:
${HOME}/.builderXcessory/classes directory
These objects appear each time you use Builder Xcessory.

· Public Classes

High-level objects that are stored in the following directory:
{BX}/XCESSORY /classes directory.
These objects appear on every Builder Xcessory user's Palette.

Palette Menus

Palette menu

Allows you to control the Palette's appearance by performing the following operations:

· Create a new Palette

· Show the Palette in full or reduced (tabbed) view

· Display the Palette icons with only pixmaps, only labels, or both

Catalog menu

Allows you to manipulate the Palette by performing the following operations:

· Create a new catalog

· Load an existing catalog

· Merge a catalog with the current catalog

· Save the current Palette catalog

· Save the Palette catalog to a different file

· Change the display name for the Palette

Edit menu

Allows you to rearrange the Palette by performing the following operations:

· Move objects from one group to another

· Change the order of the objects within a group

· Create a new group

MB3 Quick Access menu

Invoked by pressing MB3 while the mouse pointer is positioned over a Palette icon or a Palette group name. This menu provides many of the Edit menu functions. From the Quick Access menu you can perform the following operations:

· Move or delete the selected object(s)

· Create a new group

· Modify the properties of an object icon

UpPreviousNext